Monday, March 3, 2008

openoffice-bin-2.4.0-r2不能调用SCIM的问题解决方法

写了个openoffice-bin-2.4.0-r2.ebuild
然后卸载编译的ooo装好了新的OOo-bin发现不能用SCIM输入了。。

jjmmma@sabayon ~ $ oowriter
Gtk-Message: Failed to load module "gnomebreakpad": /usr/lib/openoffice/program/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/bug-buddy/libbreakpad.so.0)

(soffice:27198): Gtk-WARNING **: /usr/lib/openoffice/program/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/immodules/im-scim.so)

(soffice:27198): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:27198): Gtk-WARNING **: /usr/lib/openoffice/program/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/immodules/im-scim.so)

(soffice:27198): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:27198): Gtk-WARNING **: /usr/lib/openoffice/program/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/immodules/im-scim.so)

(soffice:27198): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:27198): Gtk-WARNING **: /usr/lib/openoffice/program/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/immodules/im-scim.so)

(soffice:27198): Gtk-WARNING **: Loading IM context type 'scim' failed

原因是OOo-bin自带一个libstdc++和libgcc,和SCIM所编译的库版本不匹配。
做一个软链接就可以了:

sabayon program # ln -sf /usr/lib/gcc/i686-pc-linux-gnu/4.2.3/libgcc_s.so.1 libgcc_s.so.1
sabayon program # ln -sf /usr/lib/gcc/i686-pc-linux-gnu/4.2.3/libstdc++.so.6 libstdc++.so.6

再次终端运行oowriter就没有报错了。

--
顺頌春祉
Jijun MA
http://jjmmma.com
Zhejiang University-Intel Technology Center
College of Computer Science, Zhejiang University, China

No comments: